Issue with upstream provider delaying email delivery
Incident Report for Memberful
Resolved
The queues are caught up and all sending is back to normal now.
Posted Feb 03, 2023 - 18:47 UTC
Identified
Our upstream provider has identified the issue and the queues are coming down rapidly. They should be back to normal shortly.
Posted Feb 03, 2023 - 18:40 UTC
Update
We are continuing to investigate this issue.
Posted Feb 03, 2023 - 18:24 UTC
Investigating
We're currently experiencing a delay in email delivery due to an issue with our upstream provider. Messages are still being delivered, but there is a delay of 10+ minutes. We'll continue to post updates while we monitor the situation and confirm when our provider has fully resolved the issue.
Posted Feb 03, 2023 - 18:23 UTC