Service Degradation

Incident Report for Memberful

Resolved

We'll consider this incident resolved since the application has been operational for the past 5 hours. We'll continue monitoring our upstream providers nevertheless.
Posted Oct 20, 2025 - 21:12 UTC

Monitoring

Our application is back online, but we'll keep monitoring it and inform you of any changes. Our upstream providers are still working on fully resolving the issue.
Posted Oct 20, 2025 - 16:18 UTC

Investigating

We’re currently experiencing service disruptions due to ongoing issues with our upstream providers (AWS and Heroku). Our team is monitoring the situation and will provide updates as they become available.
Posted Oct 20, 2025 - 15:26 UTC
This incident affected: Platform.