Issue with upstream provider delaying certain tasks
Incident Report for Memberful
Resolved
Our upstream provider has resolved the incident. Today's Metrics are updating normally and all scheduled Posts are delivering as expected.
Posted Mar 17, 2023 - 03:29 UTC
Monitoring
We're currently experiencing a delay in updating today's Metrics and delivering scheduled Posts due to an issue with our upstream provider. They'll be updated and delivered as soon as the problem has been fixed.

We'll continue to post updates while we monitor the situation and confirm when our provider has fully resolved the issue.
Posted Mar 17, 2023 - 01:17 UTC
This incident affected: Platform.