Delayed email delivery
Incident Report for Memberful
Resolved
Our upstream provider is recovering and emails are sending.
Posted Jun 17, 2024 - 22:15 UTC
Monitoring
We're monitoring delays affecting email delivery due to an incident with our upstream provider. Delayed messages will still be delivered.
Posted Jun 17, 2024 - 19:40 UTC
This incident affected: Platform.