Issue with upstream provider delaying email delivery
Incident Report for Memberful
Resolved
Our upstream provider has resolved the incident and all emails are being delivered normally.
Posted Dec 17, 2022 - 20:39 UTC
Update
Our upstream provider has identified the root cause of the issue and is working on full mitigation.

The provider is continuing to send emails and working through the queues. We will update more as we have more information.
Posted Dec 17, 2022 - 05:26 UTC
Monitoring
We're still experiencing a delay in email delivery due to an issue with our upstream provider.

They are still processing and sending emails, but with a large delay. They are working on ways to speed up the queues so that we can get through the email backlog as quickly as we can.

We'll continue to post updates while we monitor the situation and confirm when our provider has fully resolved the issue.
Posted Dec 17, 2022 - 01:07 UTC
This incident affected: Platform.