Issue with upstream provider delaying email delivery
Incident Report for Memberful
Resolved
This incident has been resolved.
Posted Dec 17, 2022 - 00:27 UTC
Monitoring
We're currently experiencing a delay in email delivery due to an issue with our upstream provider. They will be delivered as soon as the provider has fixed the issue.

We'll continue to post updates while we monitor the situation and confirm when our provider has fully resolved the issue.
Posted Dec 16, 2022 - 20:12 UTC
This incident affected: Platform.